Yay, RuboCop wins the annoying award: Naming/RescuedExceptionsVariableName: Use e instead of error.

@ioquatix That goes against one of the conventions I like about Ruby, which is to use full variable names instead of single letters. I don't understand how is that the default in Rubocop.

@janko Personally I think RuboCop makes code objectively worse, for the sake of consistency. For some situations, that's a trade-off people are willing to live with. But yeah, wow, strange defaults.

@ioquatix @janko Not just the defaults. Readability and consistency are not entirely the same thing, so I don't think any set of rules can make the code better ALL the time. But yeah, I keep making that tradeoff.

Sign in to participate in the conversation

A Mastodon instance for Rubyists & friends