Follow

rvm won't install for me. I get keys allright but somehow they cannot be used unless I sudo for key getting. RVM installation later on complains that it cannot get keys... catch22

@dekkzz78 only me on this system (some other specialized users) but it is only me :)

@ljgww_rb did it ask for sudo user +pw when it started to install?

@dekkzz78 No. Just complains it cannot open/read local key repo.

@dekkzz78 when I catch some time I will take a snapshot, so maybe you'd have some idea what to do.

@dekkzz78 Manged to install RVM. I also have RBENV. I am unsure how these two may conflict.
Apparently I have installation of default U14 ruby which is: ruby 1.9.3p484 (2013-11-22 revision 43786) [x86_64-linux] officially supported until next year. Then I have alternative ruby 2.2.0p0 (2014-12-25 revision 49005) [x86_64-linux] (that I install by compiling source) this one RBENV calls 'system' and another version is not visible.
i am not sure how these tools recognize what is what.

@ljgww_rb pick one install method and stick to it & remove the other.

@dekkzz78 I guess yes, but I think some 3 years ago I did try to install rvm and failed, then found rbenv and this one worked for me. Now that I am revisiting the subject, I have way more experience with Ubuntu's ways. 😉

@ljgww_rb rym really is distro independant, i'm lucky for my tinkering i just need 1.9 to follow the book.

@dekkzz78 ahh yes now I remember I installed rbenv... thats why I do not have another one. (I think ...?!?)

Sign in to participate in the conversation
Ruby.social

A Mastodon instance for Rubyists & friends